re = /\*\*(?=)/
str = 'I\'m searching for **my 12 funny** words *inside my* unfunny text
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result