import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<error_msg>.*?)(?:exit\\s+code:\\s+)(?P<exit_code>\\d+).(?:Stdout:)(?P<stdout>.*?)(?:Stderr:)(?P<stderr>.*?)(?:CUSTOM_EOF)";
final String string = "process \"pipenv run pylint --rcfile .linting-configs/pylintrc ci/dagger/automation.py ci/dagger/async_interface.py ci/dagger/models/linting.py ci/dagger/models/config.py ci/dagger/linting.py ci/dagger/helper.py\" did not complete successfully: exit code: 28\n"
+ "Stdout:\n"
+ "o snake_case naming style (invalid-name)\n"
+ "************* Module models.linting\n"
+ "ci/dagger/models/linting.py:9:0: C0115: Missing class docstring (missing-class-docstring)\n"
+ "ci/dagger/models/linting.py:15:22: C0103: Argument name \"v\" doesn't conform to snake_case naming style (invalid-name)\n"
+ "ci/dagger/models/linting.py:33:0: C0115: Missing class docstring (missing-class-docstring)\n"
+ "ci/dagger/models/linting.py:44:4: C0115: Missing class docstring (missing-class-docstring)\n"
+ "ci/dagger/models/linting.py:44:4: R0903: Too few public methods (0/2) (too-few-public-methods)\n"
+ "ci/dagger/models/linting.py:33:0: R0903: Too few public methods (1/2) (too-few-public-methods)\n"
+ "ci/dagger/models/linting.py:48:0: C0115: Missing class docstring (missing-class-docstring)\n"
+ "************* Module models.config\n"
+ "ci/dagger/models/config.py:6:0: C0115: Missing class docstring (missing-class-docstring)\n"
+ "ci/dagger/models/config.py:6:0: R0903: Too few public methods (0/2) (too-few-public-methods)\n"
+ "************* Module linting\n"
+ "ci/dagger/linting.py:37:4: W0613: Unused argument 'client' (unused-argument)\n"
+ "ci/dagger/linting.py:179:4: W0613: Unused argument 'client' (unused-argument)\n"
+ "ci/dagger/linting.py:240:4: W0613: Unused argument 'client' (unused-argument)\n"
+ "ci/dagger/linting.py:301:4: W0613: Unused argument 'client' (unused-argument)\n"
+ "ci/dagger/linting.py:5:0: W0611: Unused import click (unused-import)\n"
+ "ci/dagger/linting.py:7:0: W0611: Unused QueryError imported from dagger.exceptions (unused-import)\n"
+ "************* Module helper\n"
+ "ci/dagger/helper.py:51:0: C0116: Missing function or method docstring (missing-function-docstring)\n"
+ "ci/dagger/helper.py:88:0: C0115: Missing class docstring (missing-class-docstring)\n"
+ "ci/dagger/helper.py:122:0: C0116: Missing function or method docstring (missing-function-docstring)\n"
+ "ci/dagger/helper.py:133:19: W0212: Access to a protected member _raw_input of a client class (protected-access)\n"
+ "ci/dagger/helper.py:1:0: W0611: Unused getenv imported from os (unused-import)\n\n"
+ "-----------------------------------\n"
+ "Your code has been rated at 8.45/10\n"
+ "Stderr:\n"
+ "CUSTOM_EOF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}