import Foundation
let pattern = #"(fopen|fwrite)\([^$]*(,|\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
fopen($file)
fopen($file, 'w')
fopen("file" . $file)
$fp = fopen(
$file
)
$data = base64_encode(fread(fopen($val, "r"), filesize($val)));
fopen("file", $w)
fopen("file")
$fp = fopen(
"file"
)
$curlResult = fopen("/app/localhost/html/curlResult.txt", "r") or die ("unable to find");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)