package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bfoo\b|_foo_`)
var str = `foo ---foo-- abc.foo.def 123(foo)456
_foo_ (_foo_)
foofooo foo_foo
___foo___
xxx_foo_zzzz xxxfoozzz
0000 foo_
9999 _foo...
foo_abc cba_foo
a foo_ _foo bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}