$re = '/ \s*\(\p{Sc}\d[.\d]*\)/';
$str = ' TEXT (text) (€10.00)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);