const regex = /^\((\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\(?\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\d+ (AND|OR) )+\d+$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\((\\d+\\)? (AND|OR) )+\\d+(\\)|\\) .*?)$|^(\\(?\\d+\\)? (AND|OR) )+\\d+(\\)|\\) .*?)$|^(\\d+ (AND|OR) )+\\d+$', 'gim')
const str = `1 AND 2 AND 3 AND 4
1 AND 2 AND (3 AND 4)
1 AND 2 AND 3 (AND 4)
(1 AND 2 AND 3 AND 4
)1 AND 2 AND 3 AND 4
(1 AND 2 AND 3) AND 4
(1 AND 2)(AND 3 AND 4)
((1 AND 2 AND 3 AND 4)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}