$re = '/^\((\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\(?\d+\)? (AND|OR) )+\d+(\)|\) .*?)$|^(\d+ (AND|OR) )+\d+$/im';
$str = '1 AND 2 AND 3 AND 4
1 AND 2 AND (3 AND 4)
1 AND 2 AND 3 (AND 4)
(1 AND 2 AND 3 AND 4
)1 AND 2 AND 3 AND 4
(1 AND 2 AND 3) AND 4
(1 AND 2)(AND 3 AND 4)
((1 AND 2 AND 3 AND 4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);