$re = '/https:\/\/firebasestorage\.googleapis\.com\/v0\/b\/uczsieapp\.appspot\.com\/o\/images%2F/m';
$str = 'https://firebasestorage.googleapis.com/v0/b/uczsieapp.appspot.com/o/images%2F50531a3b-826c-4f8d-a597-a419eab083f0?alt=media&token=dca85b39-e6e7-43ac-bfef-d098cb33c7d3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);