# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/['"](.*?)['"]/"REPLACED"/g;t' <<< "this is \"some sting\" whatever 'another string'"