#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "['"](.*?)['"]"
Local $sString = "this is "some sting" whatever 'another string'"
Local $sSubst = ""REPLACED""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)