import Foundation
let pattern = #"['"](.*?)['"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"this is "some sting" whatever 'another string'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""REPLACED""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)