re = /^#\/(?:[A-Za-z]+(?:\/[A-Za-z]+)*)?$/m
str = '#/
#/word/word
#/word
#/word/word/word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end