import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<workspace>(@[\\w-]*)?)//(?P<package>[\\w\\-/]*)(?P<target>:(?P<target_all>all)|:(?P<target_named>[\\w\\-\\./]+)|(?P<target_recursive>\\.\\.\\.)|(?P<empty_target>(?<!/)))$";
final String string = "@saicny_robotics//devices/realsense:all\n"
+ "@saicny_robotics//devices/realsense/:all\n"
+ "@//devices/realsense/...\n"
+ "//...\n"
+ "@spybot//...\n"
+ "@spybot//:all\n"
+ "@spybot//devices/realsense\n"
+ "@spybot//devices/realsense/\n"
+ "@spybot//:path/to\n"
+ "@spybot//devices/realsense:path_to/file.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}