use strict;
my $str = '@saicny_robotics//devices/realsense:all
@saicny_robotics//devices/realsense/:all
@//devices/realsense/...
//...
@spybot//...
@spybot//:all
@spybot//devices/realsense
@spybot//devices/realsense/
@spybot//:path/to
@spybot//devices/realsense:path_to/file.txt';
my $regex = qr/(?P<workspace>(@[\w-]*)?)//(?P<package>[\w\-/]*)(?P<target>:(?P<target_all>all)|:(?P<target_named>[\w\-\./]+)|(?P<target_recursive>\.\.\.)|(?P<empty_target>(?<!/)))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}