Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?<year>\d{4})(?:(?<month>\d{2})(?:(?<day>\d{2})(?:(?<hour>\d{2})(?:(?<minute>\d{2})(?:(?<second>\d{2})(?:.(?<millis>\d{3})(?:\[(?:(?<offsetSign>[+-]?)(?<offsetHour>\d{1,2}))(?:.(?<offsetMin>\d{2}))?(?::(?<tz>.*)?)?\])?)?)?)?)?)?)?$
/
gm
Input 1
1
New
1996 199610 19961005 1996100513 199610051322 19961005132200 19961005132200.124 19961005132200.124[-5] 19961005132200.124[-5:EST] 19961005132200.124[-5.30:EST] 19961005132200.124[-5.30:] 19961005132200.124[-5.30] 19961005132200.124[+5] 19961005132200.124[+5.30] 19961005132200.124[+5:EST] 19961005132200.124[+5.30:EST] 19961005132200.124[+5.30:] 19961005132200.124[5] 19961005132200.124[5.30] 19961005132200.124[5:EST] 19961005132200.124[5.30:EST] 19961005132200.124[5.30:]