using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(ul|ol)>\s*<li>{([ .\w-]+)} *(.*?)<\/\1>";
string input = @"
<ul>
<li>{ .class .asdf}some item</li>
<li>another</li>
</ul>
<ul>
<li>{.class} some item</li>
<li>another</li>
</ul>
<p>{.test}Content of the paragrap
</p>
<([a-z\-]+)>{([ \w\.-]+)} *(.*?)<\/\1>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}