const regex = /<(ul|ol)>\s*<li>{([ .\w-]+)} *(.*?)<\/\1>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(ul|ol)>\\s*<li>{([ .\\w-]+)} *(.*?)<\\\/\\1>', 'gms')
const str = `
<ul>
<li>{ .class .asdf}some item</li>
<li>another</li>
</ul>
<ul>
<li>{.class} some item</li>
<li>another</li>
</ul>
<p>{.test}Content of the paragrap
</p>
<([a-z\\-]+)>{([ \\w\\.-]+)} *(.*?)<\\/\\1>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}