$re = '/[a-zA-Z]{2}\-[0-9]{2}\-[0-9]{2}\-[0-9]{4}|[a-zA-Z0-9]{4}\-[0-9]{2}\-[0-9]{4}/';
$str = 'AM-08-12-5678lkj lkjAM-08-12-0502h fgh
AM-08-12-1234f ghfghfgh
AM-08-12-5678fghfghfghT148-16-0501';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);