using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<audio\s+src=""([^""]*)""[^>]*>";
string input = @"<p><audio src=""test.mp3"" controls=""controls""></audio></p>
<p><audio src=""test2.mp3"" controls=""controls""></audio></p>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}