re = /<audio\s+src="([^"]*)"[^>]*>/i
str = '<p><audio src="test.mp3" controls="controls"></audio></p>
<p><audio src="test2.mp3" controls="controls"></audio></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end