re = /(?<!Mathf.)(?<=\W)(Cos|Sin|Tan|Asin|Acos|Atan|Sgn|Sqr)(?=\W)/m
str = ' alpha=(Mathf.Sin(GameTime/1.3f)+1.4f)/2
return Sgn Mathf.Sin(-90+Angle*-1);
Local float AC=v[1]*2 , float AB=v[0]*2 ,float BC=Sqr(AC^2 + AB^2);'
subst = 'Mathf.$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result