using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"chip=""(?<value>[^""]+)|chip_name=""(?<text>[^""]+)";
string input = @"node_hwmon_chip_names{chip=""0000:d7:00_0_0000:d8:00_0"",chip_name=""enp216s0f0np0""} 1
node_hwmon_chip_names{chip=""0000:d7:00_0_0000:d8:00_1"",chip_name=""enp216s0f0np1""} 1
node_hwmon_chip_names{chip=""0000:d7:00_0_0000:d8:00_2"",chip_name=""enp216s0f0np2""} 1
node_hwmon_chip_names{chip=""0000:d7:00_0_0000:d8:00_3"",chip_name=""enp216s0f0np3""} 1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}