#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[1-578]\d\d|(?:0\d[1-9]|0[1-9]\d)|(?:6\d[0-57-9]|6[0-57-9]\d)"
Local $sString = "I am supposed to exclude the numbers 000, 666, and all numbers between 900-999." & @CRLF & _
"" & @CRLF & _
"001" & @CRLF & _
"000" & @CRLF & _
"002" & @CRLF & _
"100" & @CRLF & _
"600" & @CRLF & _
"660" & @CRLF & _
"666" & @CRLF & _
"606" & @CRLF & _
"900" & @CRLF & _
"899" & @CRLF & _
"999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")