$re = '/^[0-9]{3,4}[х ]+[0-9]{3,4}/m';
$str = '1280х720
1280х720 (х кириллица)
1280 х 720
1280 х 720 (х кириллица)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);