using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<degrees>-?\d+)(?P<decimal_minutes>\d{2}.*)";
string substitution = @"\g<degrees> \g<decimal_minutes>";
string input = @"-7045.886002
7203.23423
11023.2343
-17323.2343
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}