import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<degrees>-?\\d+)(?P<decimal_minutes>\\d{2}.*)";
final String string = "-7045.886002\n"
+ "7203.23423\n"
+ "11023.2343\n"
+ "-17323.2343\n";
final String subst = "\\g<degrees> \\g<decimal_minutes>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}