const regex = new RegExp('^(?P<degrees>-?\\d+)(?P<decimal_minutes>\\d{2}.*)', 'gm')
const str = `-7045.886002
7203.23423
11023.2343
-17323.2343
`;
const subst = `\g<degrees> \g<decimal_minutes>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);