$re = '/^(?P<degrees>-?\d+)(?P<decimal_minutes>\d{2}.*)/m';
$str = '-7045.886002
7203.23423
11023.2343
-17323.2343
';
$subst = "\g<degrees> \g<decimal_minutes>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;