// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<degrees>-?\d+)(?P<decimal_minutes>\d{2}.*)").unwrap();
let string = "-7045.886002
7203.23423
11023.2343
-17323.2343
";
let substitution = "\\g<degrees> \\g<decimal_minutes>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}