re = /(?P<Flat>([A-Za-z0-9\/\-]*\w\s*)*)(\,|\s|\|)*(?P<Building>([A-Za-z0-9\s\/\-]*\w\s*)(\,|\s)*)(?P<OtherPart>([A-Za-z\s\/\-\,]*\w\s*)(\,|\s)*)(?P<PinCode>([0-9]{6}))/m
str = '168-B-A-3, LIG Flats, yur Vihar Phase-3, Vasundhra nclave, East Delhi, Vasundhra nclave, Delhi, 110096'
subst = '\\1\\2 \\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result