re = /^ {0,3}[\-][ \t]*[\-][ \t]*[\-][\- \t]*$|^ {0,3}[\*][ \t]*[\*][ \t]*[\*][\* \t]*$|^ {0,3}[_][ \t]*[_][ \t]*[_][_ \t]*$/m
str = '- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end