#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\d{4}\-\d{2}\-\d{2}))(\n|.)*?(?=(\d{4}\-\d{2}\-\d{2}))"
Local $sString = "" & @CRLF & _
"2018-12-04" & @CRLF & _
"sdfsdgdn dfgdfhfghfgh fgs gf gssfgdsf" & @CRLF & _
"dsfgdfh" & @CRLF & _
"dfsghgfhdfg" & @CRLF & _
"" & @CRLF & _
"gfhgfhd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2018-12-03" & @CRLF & _
"cewe4fertger4y hrty wedsgse" & @CRLF & _
"gb" & @CRLF & _
"dfshfhd" & @CRLF & _
"hgfdh" & @CRLF & _
"" & @CRLF & _
"dfsghdshd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2018-12-02" & @CRLF & _
"gffvdgsdhysd gfhfdfgcncfgh" & @CRLF & _
"f frhbn 5ryrthe54trbgf " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")