# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\d{4}\-\d{2}\-\d{2}))(\n|.)*?(?=(\d{4}\-\d{2}\-\d{2}))"
test_str = ("\n"
"2018-12-04\n"
"sdfsdgdn dfgdfhfghfgh fgs gf gssfgdsf\n"
"dsfgdfh\n"
"dfsghgfhdfg\n\n"
"gfhgfhd\n\n\n"
"2018-12-03\n"
"cewe4fertger4y hrty wedsgse\n"
"gb\n"
"dfshfhd\n"
"hgfdh\n\n"
"dfsghdshd\n\n\n"
"2018-12-02\n"
"gffvdgsdhysd gfhfdfgcncfgh\n"
"f frhbn 5ryrthe54trbgf \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.