using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?:\\""|[^""])*""";
string input = @"And then, ""this is some sample text with quotes and \""escaped quotes\"" inside"". Not that we need more, but... ""here is \""another\"" one"". Just in case.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}