re = /(?=["'])(?:"[^"\\]*(?:\\[\s\S][^"\\]*)*"|'[^'\\]*(?:\\[\s\S][^'\\]*)*')|(#.*$)/m
str = 'class AAA:
"""
item
"""
\'\'\'\'
SRC_TYPE = (
(\'cs\', \'src C# for all\'), # this is a comment a \'comment\'
(\'cpp\', \'C++\'),
(\'ascript\', \'a \'),#djshdjshdjshds
(\'script\', \'tst C#\')
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end