# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<dq>\"[^"]*)\s*\")|((?<sq>\'[^']*)\s*\')|((?<bt>\`[^`]*)\s*\`)| /$1$2$3/gi;t' <<< "function myFunction() {
let carName = \"Volvo\";
// code here CAN use carName
const test = 'string with \"quoted substring\"';
(\"and another string th'' as' asd 'ere\")
labelForStrings: {
`t'is a \"string\"`
}
}
/*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/"