# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/folder\\/[^?]+\?)[^=\s]+=[^=\s]+=[^&\s]+&.*(?=\s|$)/\1REPLACE-1=REPLACE-2=REPLACE-3&REPLACE-4/gm;t' <<< "domain.com/folder/random-text-1?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4=B2"