#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\/folder\/[^?]+\?)[^=\s]+=[^=\s]+=[^&\s]+&.*(?=\s|$)"
Local $sString = "domain.com/folder/random-text-1?A1=A2=A3&A4" & @CRLF & _
"domain.com/folder/random-text-2?B1=B2=B3&B4=B2"
Local $sSubst = "\1REPLACE-1=REPLACE-2=REPLACE-3&REPLACE-4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)