using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/folder\/[^?]+\?)[^=\s]+=[^=\s]+=[^&\s]+&.*(?=\s|$)";
string substitution = @"\1REPLACE-1=REPLACE-2=REPLACE-3&REPLACE-4";
string input = @"domain.com/folder/random-text-1?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4=B2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}