use strict;
my $str = '<select data-testid=\\"price-max-select\\"><option value=\\"\\">Beliebig</option><option value=\\"500\\">500 €</option><option value=\\"1000\\">1.000 €</option><option value=\\"1500\\">1.500 €</option><option value=\\"2000\\">2.000 €</option><option value=\\"2500\\">2.500 €</option><option value=\\"3000\\">3.000 €</option><option value=\\"3500\\">3.500 €</option><option value=\\"4000\\">4.000 €</option><option value=\\"4500\\">4.500 €</option><option value=\\"5000\\">5.000 €</option><option value=\\"6000\\">6.000 €</option><option value=\\"7000\\">7.000 €</option><option value=\\"8000\\">8.000 €</option><option value=\\"9000\\">9.000 €</option><option value=\\"10000\\">10.000 €</option><option value=\\"11000\\">11.000 €</option><option value=\\"12000\\">12.000 €</option><option value=\\"13000\\">13.000 €</option><option value=\\"14000\\">14.000 €</option><option value=\\"15000\\">15.000 €</option><option value=\\"17500\\">17.500 €</option><option value=\\"20000\\">20.000 €</option><option value=\\"22500\\">22.500 €</option><option value=\\"25000
+KLIMA+TEMPOMAT+EURO 5</span></div></div><div class=\\"g-col-5\\"><div class=\\"price-block u-margin-bottom-9\\"><span class=\\"h3 u-block\\">3.100 €</span><span class=\\"link financing-integration-lp-links\\" data-budgetstatus=\\"default\\" data-prg-href=\\"https://www.mobile.de/finanzierung/route/outlink/1?adId=361635483&loanDuration=60
e+KLIMA+TEMPOMAT+EURO 5</span></div></div><div class=\\"g-col-5\\"><div class=\\"price-block u-margin-bottom-9\\"><span class=\\"h3 u-block\\">100 €</span><span class=\\"link financing-integration-lp-links\\" data-budgetstatus=\\"default\\" data-prg-href=\\"https://www.mobile.de/finanzierung/route/outlink/1?adId=361635483&loanDuration=60"
"e+KLIMA+TEMPOMAT+EURO 5</span></div></div><div class=\\"g-col-5\\"><div class=\\"price-block u-margin-bottom-9\\"><span class=\\"h3 u-block\\">3.100 €</span><span class=\\"link financing-integration-lp-links\\" data-budgetstatus=\\"default\\" data-prg-href=\\"https://www.mobile.de/finanzierung/route/outlink/1?adId=361635483&loanDuration=60
e+KLIMA+TEMPOMAT+EURO 5</span></div></div><div class=\\"g-col-5\\"><div class=\\"price-block u-margin-bottom-9\\"><span class=\\"h3 u-block\\">20.100 €</span><span class=\\"link financing-integration-lp-links\\" data-budgetstatus=\\"default\\" data-prg-href=\\"https://www.mobile.de/finanzierung/route/outlink/1?adId=361635483&loanDuration=60"
';
my $regex = qr/(?<=class=\\"h3 u-block\\">)[\d\.]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}