# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=class=\\\"h3 u-block\\\">)[\d\.]+"
test_str = ("<select data-testid=\\\"price-max-select\\\"><option value=\\\"\\\">Beliebig</option><option value=\\\"500\\\">500 €</option><option value=\\\"1000\\\">1.000 €</option><option value=\\\"1500\\\">1.500 €</option><option value=\\\"2000\\\">2.000 €</option><option value=\\\"2500\\\">2.500 €</option><option value=\\\"3000\\\">3.000 €</option><option value=\\\"3500\\\">3.500 €</option><option value=\\\"4000\\\">4.000 €</option><option value=\\\"4500\\\">4.500 €</option><option value=\\\"5000\\\">5.000 €</option><option value=\\\"6000\\\">6.000 €</option><option value=\\\"7000\\\">7.000 €</option><option value=\\\"8000\\\">8.000 €</option><option value=\\\"9000\\\">9.000 €</option><option value=\\\"10000\\\">10.000 €</option><option value=\\\"11000\\\">11.000 €</option><option value=\\\"12000\\\">12.000 €</option><option value=\\\"13000\\\">13.000 €</option><option value=\\\"14000\\\">14.000 €</option><option value=\\\"15000\\\">15.000 €</option><option value=\\\"17500\\\">17.500 €</option><option value=\\\"20000\\\">20.000 €</option><option value=\\\"22500\\\">22.500 €</option><option value=\\\"25000\n"
"+KLIMA+TEMPOMAT+EURO 5</span></div></div><div class=\\\"g-col-5\\\"><div class=\\\"price-block u-margin-bottom-9\\\"><span class=\\\"h3 u-block\\\">3.100 €</span><span class=\\\"link financing-integration-lp-links\\\" data-budgetstatus=\\\"default\\\" data-prg-href=\\\"https://www.mobile.de/finanzierung/route/outlink/1?adId=361635483&loanDuration=60\n"
"e+KLIMA+TEMPOMAT+EURO 5</span></div></div><div class=\\\"g-col-5\\\"><div class=\\\"price-block u-margin-bottom-9\\\"><span class=\\\"h3 u-block\\\">100 €</span><span class=\\\"link financing-integration-lp-links\\\" data-budgetstatus=\\\"default\\\" data-prg-href=\\\"https://www.mobile.de/finanzierung/route/outlink/1?adId=361635483&loanDuration=60\"\n"
"\"e+KLIMA+TEMPOMAT+EURO 5</span></div></div><div class=\\\"g-col-5\\\"><div class=\\\"price-block u-margin-bottom-9\\\"><span class=\\\"h3 u-block\\\">3.100 €</span><span class=\\\"link financing-integration-lp-links\\\" data-budgetstatus=\\\"default\\\" data-prg-href=\\\"https://www.mobile.de/finanzierung/route/outlink/1?adId=361635483&loanDuration=60\n"
"e+KLIMA+TEMPOMAT+EURO 5</span></div></div><div class=\\\"g-col-5\\\"><div class=\\\"price-block u-margin-bottom-9\\\"><span class=\\\"h3 u-block\\\">20.100 €</span><span class=\\\"link financing-integration-lp-links\\\" data-budgetstatus=\\\"default\\\" data-prg-href=\\\"https://www.mobile.de/finanzierung/route/outlink/1?adId=361635483&loanDuration=60\"\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.