# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"string_value:(?=(?:(?!attributes_cache).)*name: last_name)\s+\"(\w+)\".*?attributes_cache"
test_str = ("\\- !ruby/object:DynamicAttribute \n"
" attributes: \n"
" resource_id: \"1\"\n"
" resource_type: Applicant\n"
" string_value: \"Johnson1\"\n"
" int_value: \n"
" id: \"35533149\"\n"
" date_value: \n"
" name: last_name\n"
" attributes_cache: {}\n\n"
"\\- !ruby/object:DynamicAttribute \n"
" attributes: \n"
" resource_id: \"1\"\n"
" resource_type: Applicant\n"
" string_value: \"Michael\"\n"
" int_value: \n"
" id: \"35972390\"\n"
" date_value: \n"
" name: first_name\n"
" attributes_cache: {}\n\n"
"\\- !ruby/object:DynamicAttribute \n"
" attributes: \n"
" resource_id: \"1\"\n"
" resource_type: Applicant\n"
" string_value: \"Johnson2\"\n"
" int_value: \n"
" id: \"35533149\"\n"
" date_value: \n"
" name: last_name\n"
" attributes_cache: {}")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.