using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?(DEFINE)
(?<warranty_word> ([a-zäöüßÖÜÄ0-9-]+)?garantie[*]?)
)
(?&warranty_word)";
string input = @"3 Jahre Vor-Ort-Garantie";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}