re = /\bPort\s+\S+(?:\s+\S+)?/m
str = 'Strong winds may disrupt operations at the Port of Rotterdam on July 5
Strong winds may disrupt operations at the Port of'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end