// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bPort\s+\S+(?:\s+\S+)?").unwrap();
let string = "Strong winds may disrupt operations at the Port of Rotterdam on July 5
Strong winds may disrupt operations at the Port of";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}