#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\[(WIP|Draft)\]|(WIP|Draft))(:|\s)?"
Local $sString = "[WIP]: lulz" & @CRLF & _
"[Draft]: hahaha" & @CRLF & _
"[Draft] lalalala" & @CRLF & _
"WIP: blah" & @CRLF & _
"WIP m000" & @CRLF & _
"Draft: foo" & @CRLF & _
" Draft: nope" & @CRLF & _
" WIP: more nope" & @CRLF & _
"WIP yeeeep" & @CRLF & _
"WIP:ahoy" & @CRLF & _
"WIP: ahoy matey!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")