#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)"
Local $sString = "<!-- single-line -->" & @CRLF & _
"<!-- <!-- nested single-line -->" & @CRLF & _
"not a comment" & @CRLF & _
"<!--" & @CRLF & _
" <!-- nested multiline" & @CRLF & _
"-->" & @CRLF & _
" <!--" & @CRLF & _
" multiline" & @CRLF & _
" -->" & @CRLF & _
" <!-- truncated"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)