using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)";
string substitution = @"";
string input = @"<!-- single-line -->
<!-- <!-- nested single-line -->
not a comment
<!--
<!-- nested multiline
-->
<!--
multiline
-->
<!-- truncated";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}