re = /(<!--.*?-->)|(<!--[\S\s]+?-->)|(<!--[\S\s]*?$)/
str = '<!-- single-line -->
<!-- <!-- nested single-line -->
not a comment
<!--
<!-- nested multiline
-->
<!--
multiline
-->
<!-- truncated'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result