package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<command.+(?:valid|executed)="(?<val>[^"]+)"\s*\/>`)
var str = `<command valid="true" />
<command name="LoadDocument" executed="true" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}